Flash课件网 - 您身边的课件制作专家
Flash课件网官方,专业代做课件、定制原创Flash动画或参赛课件、修改Flash、制作演讲或汇报幻灯片PPT课件。联系QQ:4318100或搜索微信号:flashkj

PPT里插入flash文件弹出安全提示问题的解决办法汇总

本站提供Flash课件代做和PPT幻灯片定制业务,联系QQ/微信:4318100

    对于大多数老师来说,直接制作FLASH课件难度太大,但纯PPT又显得太过简单,线性的呈现方式不能满足课堂教学的需要,故在PPT中插入SWF文件不失为一种兼顾二者的好方法,关于在PPT中嵌入SWF文件的方法,本站在之前的文章中做过详细介绍,在此就不再累赘,如不了解的朋友可以点击此文了解:在PowerPoint中插入Flash及控件属性参数设置,在这篇文章中不仅介绍了详细的插入方法,还解决了部分机器在插入过程中出现问题的解决办法。最近不少老师向我们咨询在PPT中嵌入FLASH后在实际教学或展示播放过程产生的弹出安全提示窗的问题,即在放映PPT文件时候,播放到含有SWF文件的页面时候,页面弹出完全提示窗口:“此文档包含的嵌入内容可能对您的计算机有害。请从下列选项中选择一个:不允许播放内容(建议)和我可以识别此内容。允许播放。”这个问题虽然本质上不影响课件的播放和展示,但在实际应用过程中,显得较为繁琐,每次都需要选择允许播放后才能顺利进行。影响展示效果,鉴于此类需求教大,现对此类问题进行一个全面的探讨,并给出几种解决方法供大家参考:

    其实究其原因,此问题是更新Adobe flash player for IE 插件造成的,目前此版本最新升级版本为11.6,加强了安全性能,导致office播放嵌入的flash文档,弹出是否允许对话框,非常的讨嫌!解决办法是可以到网上下载个“Flash Player修复一键快速安装包 11.3”即可解决。还可以还原操作系统镜像,恢复到原来的初始状态,直接播放嵌入flash。第二种方式不自动升级flash for IE插件以及相关漏洞,版本在11.3以下即可(好像升级后就无法安装低版本的flash 插件,真有点头痛),更改PPT里面宏安全等级无法解决此问题的。

    那么如何成功安装Adobe flash player for IE  11.3以前版本呢?安装旧版前需要先把注册表的 flash player 安装信息删掉,不然会一直提示“不是最新版本flash player” 。操作如下:开始->运行->输入regedit,找到以下位置:[HKEY_LOCAL_MACHINE\SOFTWARE\Macromedia\FlashPlayer\SafeVersions],将里面的所有项目都删除后再安装旧版。

    第三种解决方法是从根源上找原因,既然是flash player版本的问题导致的安全提示,那么我们在发布FLASH文件时候可以选择低版本的flash player发布,这样插入到PPT中后也不会再有类似讨厌的提示了,当然这样做的前提是必须是自己制作的含有FLA源文件的情况下才可以,所以,前两种解决方案在实际播放中可能更为有效和直接。

  各位朋友可以根据自己的情况选择一种方法对此类问题进行完美修复,以避免弹出讨厌的安全提示问题,造成课件使用过程中的瑕疵。

标签:PPTFlashswf安全提示解决插件升级
分类:资讯转载| 发布:huagui| 查看: | 发表时间:2014-4-12
原创文章如转载,请注明:转载自Flash课件网 http://www.flashkj.com/
本文链接:http://www.flashkj.com/tuijian/344.html

已经有 ( 1 ) 位网友发表了评论,你也评一评吧!

以避免弹出讨厌的安全提示问
这个挺好用的,不会很难
Design By Flashkj.Com | Login | Power By Chen Feiyang.